Translations of this page:

This page describes some of the reported issues with the Zotero word processor plugins, together with possible solutions.

All Plugins/Platforms

Formatting issues

Citations and bibliographies generated by the word processor plugins might appear in a different style (font, font-size, etc) than the surrounding text. The appearance of the generated text can be changed by changing the default style. For example, in LibreOffice, open the Styles Manager in Format → Styles and Formatting or by pressing F12. Right-click on “Default”, select “Modify”, and make the desired changes to this style. In Word, open the Styles Manager in Format → Styles or by clicking the “Styles Pane” or “Manage Styles” buttons on the “Home” tab of the ribbon.

Bibliography formatting is controlled by the citation style you select in Zotero document preferences and should conform to the requirements of the style in use. The formatting of the bibliography can be modified by editing the “Bibliography” (Word) or “Bibliography 1” (LibreOffice) word processor style.

Zotero toolbar doesn't appear

If the Zotero toolbar (or Zotero scripts menu for Word 2008/2011 for Mac) does not appear, follow these steps:

  1. Close Word or LibreOffice.
  2. In Zotero, go to Tools → Add-ons → Extensions.
    1. If “Zotero Word for Mac/Windows Integration” or “Zotero LibreOffice Integration” are disabled, click the Enable button to re-enable the extension.
    2. If you don't see “Zotero Word for Mac/Windows Integration” or “Zotero LibreOffice Integration” in the Extensions window, then you should re-download and re-install Zotero. It is not necessary to uninstall Zotero before re-installing; simply install Zotero over the top of the existing installation. (Note: Re-installing Zotero rarely fixes problems and should not be used as a general troubleshooting step. This is one of the few instances where re-installation is helpful.)
  3. In the Cite pane of Zotero preferences, open the “Word Processors” tab.
  4. Click “Reinstall LibreOffice/Microsoft Word Add-in” and then restart your word processor.

If you are still experiencing issues, follow these software specific troubleshooting ​steps:

Debugging broken documents

If you can insert citations into new documents but receive an error in an existing document, follow these steps to find the cause of the error:

  1. While troubleshooting, disable the Track Changes feature in Word/LibreOffice, as it can have complicated effects when working with Zotero. If Track Changes is enabled when you insert or modify a Zotero citation, it may mark many or all of the Zotero citations in your document as changed or cause field codes to be displayed. On rare occasions, Tracked Changes may cause Zotero to think a citation is corrupted. If you had Track Changes enabled previously, try accepting all changes to see if that resolves the issue.
  2. Check for citations in image captions. Zotero won't let you insert them, but if you copied a citation to a caption that's most likely the source of the problem. Delete it.
  3. Try copying and pasting the document content into a new document to see if the problem goes away. You may need to click the “Set Document Preferences” button before your old citations will be recognized.
  4. Make a copy of your document — by duplicating the file itself, not by copying and pasting the content — to use for debugging.
  5. Open the copied file and check if you get the error after switching to a different bibliography style.
  6. If the document has a bibliography, delete it and check if you still get the error.
  7. Check “Report Errors…” in the Zotero Help menu to see if new errors appear after attempting to insert a citation. If so, send in an error report and post the provided Report ID to the forums.
  8. Try to isolate the problematic citation. Delete half of the document at a time and see if the error still occurs. If not, use Undo to restore the deleted section and then try deleting the other half. If you can reproduce the error in only one of the halves, repeat the halving process on the remaining section. Continue this until you find the problematic citation. Remove that citation from the original document and the problem should go away (unless there are multiple problematic citations, in which case you'll have to repeat the process). If you are able to find a problematic citation, you should also send that document excerpt to support@zotero.org so we can take a look at it. For all other discussion, please post to the Zotero forums.
  9. While debugging, if you are using Fields mode in Word or Reference Marks mode in LibreOffice, it may help to display field codes rather than formatted text. To do this in Word, press Alt/Option-F9 (or Alt-Fn-F9; Word) or Ctrl-F9 (LibreOffice).

Field codes instead of citation/bibiliography text

By default, Zotero stores the reference data for citations and the bibliography in Fields (Word) or Reference Marks (LibreOffice), which stores items' reference data hidden behind the formatted text.

If Word or LibreOffice is showing the field codes, rather than the formatted text, you can hide the field codes by pressing Alt/Option-F9 (or Alt-Fn-F9; Word) or Ctrl-F9 (LibreOffice).

If you see field codes showing repeatedly, check your word proccessor settings for displaying fields. In Word for Windows, open Word Options, then choose “Advanced” and uncheck the “Show field codes instead of their values” box. In Word for Mac, open Word → Preferences → View and uncheck the “Field codes instead of values” box in the “Show in Document” area. In LibreOffice, open Tools → Options → LibreOffice Writer → View, and uncheck the “Field codes” box in the “Display” area.

When using Track Changes, Word or LibreOffice will sometimes show you the changed and original versions of changed field codes. If this occurs, click “Accept” twice to quickly accept the changed citations and hide the field codes again.

See also Field Codes.

Citations/bibliography highlighted

Word and LibreOffice will highlight Fields/Reference Marks on your screen to indicate that the text is automatically generated. This can help you avoid accidentally manually typing in the fields (to edit the text shown in a Zotero citation, see Customizing Cites). These highlights are only shown on screen and won't appear if you print or save the document as a PDF.

You can change the settings for highlighting Fields/Reference Marks in your word processor:

  • Word for Windows: In Word Options, open “Advanced”, then set “Field shading” to “Never”, “Always”, or “When selected”.
  • Word for Mac: Open Word → Preferences → View and set “Field shading” to “Never”, “Always”, or “When selected”.
  • LibreOffice: Open Tools → Options → LibreOffice → Application Colors and check/uncheck the “Field shadings” box. You can also control the color used for field shadings.

See also Citations Highlighted.

Citations converted to plain text

If you have previously inserted citations into Word or LibreOffice using Zotero, but they have now been converted to plain text, this may be caused by one of several factors.

  1. You used the “Unlink Citations” button. This button will disconnect your document from Zotero and convert all citations and bibliographies to plain text.
  2. You saved the document in an unsupported file type. For Word, your document must be saved as .docx or .doc. For LibreOffice, if you are storing citations as Reference Marks (the default), your document must be saved as .odt. For LibreOffice, if you are storing citations as Bookmarks (see below), your document must be saved as .docx or .doc.
  3. You opened and saved your document using a word processor program that does not support Fields/Reference Marks/Bookmarks. These include:
    1. Google Docs and other online word processors: Google Docs and most other online word processors do not support Fields/Reference Marks/Bookmarks. Opening a document in these programs will break connections with Zotero. Microsoft's Word Online does support Fields and so can be used safely with Word documents containing Zotero fields.
    2. Pages: Apple Pages does not support Fields/Reference Marks/Bookmarks. Opening a document in Pages will break connections with Zotero.
    3. Word: If you open an .odt file (created by LibreOffice) in Word, Zotero references stored as Reference Marks (the default) will be broken. To share a document between Word and LibreOffice users, change the “Store Citations as:” option in the Zotero Document Preferences to Bookmarks. (Bookmarks can cause errors if accidentally modified, so they should only be used if compatibility between Word and LibreOffice is necessary.)
    4. LibreOffice: If you open a .docs or .doc file (created by Word) in LibreOffice, Zotero references stored as Fields (the default) will be broken. To share a document between Word and LibreOffice users, change the “Store Citations as:” option in the Zotero Document Preferences to Bookmarks. (Bookmarks can cause errors if accidentally modified, so they should only be used if compatibility between Word and LibreOffice is necessary.)

If your document's citations have been converted to plain text, your only option for restoring the links to Zotero is to open and restore a previous version of the document with the citation links intact. If this is not possible, you will need to re-insert the citations from Zotero.

See also Citations Converted to Plain Text.

Word

Windows

Communication error or non-responsive plugin buttons

“Word could not communicate with Zotero. Please ensure Zotero is running and try again.” Or plugin appears and buttons are clickable, but no insert citation window appears.

  1. Ensure that Zotero Word for Windows Integration is enabled in Tools → Add-ons→ Extensions.
  2. Make sure that you're running Zotero as the same user as Word. The plugin will fail, for example, if Zotero is run as administrator and Word as a regular user. For security reason you should typically not run any software as administrator.
  3. If you use ZoneAlarm, disable ForceField, which is known to cause a communication error.
  4. Windows plugins communicate with Zotero using the remote window. Thus, launching Zotero with the -no-remote command-line option will prevent the plugins from functioning. (You might do this accidentally if you have multiple Zotero profiles.) The solution is to remove the -no-remote command-line option from the shortcut used to launch the Zotero profile (this flag should never be used with Zotero).

Zotero tab does not appear in the Word Ribbon

If you are using Microsoft Office Starter Edition, Zotero Word integration is not supported.

Check if Zotero plugin is correctly installed

  1. Open Word Options
  2. Choose “Customize Ribbon”
  3. On the right pane tick the “Developer” tab
  4. Close the options and in the new Developer tab click “Word Add-ins”
  5. Make sure Zotero.dotm is present and ticked

If Zotero.dotm is present and ticked under Word Add-ins

  1. Open Word Options
  2. Choose “Trust Centre” and in the pane click “Trust Centre Settings…”
  3. Under “Add-ins” make sure that “Require Application Add-ins to be signed by Trusted Publisher” and “Disable all Application Add-ins” are unchecked.
  4. Restart Word.

If the Zotero tab is still not present after these steps, go back into the Trust Centre Settings and pick “Disable all macros with notification” under “Macro Settings”. Restart Word and see if you get a notification asking for macro permissions.

If Zotero.dotm is not present under Word Add-ins

  1. Go into Zotero → Tools → Add-ons and make sure that Zotero Word for Windows Integration is enabled. If it is disabled, enable it and restart Word.
    1. If Zotero Word for Windows Integration is missing entirely from the Add-ons window, see Zotero toolbar doesn't appear.
  2. Go into Zotero Preferences → Cite → Word Processors and click “Install Word for Windows Add-in”. Restart Word.

If Zotero tab is not present in Word, check whether it is available under Word Add-ins and if so, follow the section above. If it still does not show up in Word Add-ins, you should attempt a manual installation

Word 2010: "Could not find a running Word instance"

If you install Zotero with Word 2010 and receive an error stating

“Zotero experienced an error updating your document. [zoteroWinWordIntegration Exception… “Could not find a running Word instance.” code: “0” function: “zoteroWinWordDocument::initFromActiveObject” location: ”.\zoteroWinWordDocument.cpp”]“

you may be experiencing an issue relating to your Word 2010 installation method. Microsoft distributes a set of “Click-to-Run” versions of Office 2010 that are configured to run within their own virtual environment. Unfortunately, this virtual environment prohibits Zotero from communicating with these Word instances, producing an error.

You can fix this problem by switching your copy of Office 2010 from a Click-to-Run installation to a standard (MSI-based) installation. This process does not require an additional license. To do so, follow the steps under the “Workaround” heading on this page.

You may also experience this error if you are running either Word or Zotero as Administrator or in a compatibility mode in Windows Vista or 7, or if security software is interfering with Zotero's ability to communicate with Word.

"This command is not available because no document is open"

Zotero's Word add-on currently does not work for documents in OneDrive. Move your document to a different folder. Other cloud-syncing services such as Dropbox or Google Drive are not affected (note that Zotero documents should not be opened or edited in Google Drive's word proccessor as this will break Zotero citations. See this thread for details and developments.

Citations remain in endnotes when switching to in-text style

When switching from a note-based style set to “Endnotes” under Set Document Preferences to a style that produces in-text citations (author-date or numeric), the citations remain in endnotes.

Workaround: Before switching to the in-text style, click on “Set Document Preferences” in the Word add-on and switch the format to “Footnotes.” Then switch to the in-text style. If you did already switch to the in-text style and are seeing this issue, switch back to the note-based style you were using, toggle to “Footnotes,” and switch back.

Mac

Tab does not appear in Word 2016

Begin by updating Word to the latest version (15.40 or above).

If the tab still does not appear, check whether the plugin was installed in Word correctly:

  1. Open Word Preferences
  2. Click View
  3. Check “Show developer tab” and close the preferences dialog
  4. In the new Developer tab click “Word Add-ins”
  5. Make sure that “Zotero.dotm” is present under Global Templates and Add-ins” and is checked

If the “Zotero.dotm” entry isn't present in the dialog, try reinstalling the Word plugin from Zotero. In Zotero, go to the Cite pane of the Zotero preferences, click the “Reinstall Word Components” button, and then restart Word.

If the entry is still not present, follow the manual installation instructions.

Toolbar does not appear in Word 2004/2011 or is incompatible

First, check whether “Zotero Bibliographic Management” shows up in the View → Toolbars menu within Word. If it does but it isn't enabled, enable it.

If the Zotero option doesn't show up in that menu, try reinstalling the Word plugin from Zotero. In Zotero, go to the Cite pane of the Zotero preferences, click the “Reinstall Microsoft Word Add-in” button, and then restart Word. If the toolbar is still not present, you may try installing the plugin manually.

On a system with a non-English version of Office 2004 for Mac installed or with a non-administrator macOS user account, the toolbar may not appear in Word.

If you have a non-English version of Office, you may need to move the Zotero.dot file into the “Word” directory within the equivalent of “Startup” in your language and restart Word. The correct path should be listed in Tools→Templates and Add-ins in Word.

If you're using a non-admin macOS user account, you will need to install the Word plugin from an administrative account or grant write access for the startup directory to the non-admin account to allow it to install Zotero.dot.

Scripts do not appear in Word 2008/2011 or are incompatible

After installing the latest Word plugin for Zotero on a system with a non-English version of Office 2008/2011 for Mac installed, the plugin scripts may not appear in Word. Alternatively, after upgrading the plugin, you may receive a message saying that the plugin is incompatible with the installed version of Zotero.

These problems indicate that the new scripts were not installed into the correct location. By default, Zotero installs the scripts into ~/Library/Application Support/Microsoft/Office/Word Script Menu Items or ~/Documents/Microsoft User Data/Office/Word Script Menu Items if either of these folders exist, or asks where to install them if it does not. Since non-English versions of Office prior to Office 2011 SP2 do not use the Microsoft User Data folder, but rather a folder with an equivalent name in the Office language, this can be problematic for non-English Office users. There are three potential solutions:

  1. If you have Office 2011, install the latest available updates. You can then reinstall the Word scripts from Zotero. In Zotero, go to the Cite pane of Zotero preferences, click the “Reinstall Microsoft Word Add-in” button, and then restart Word. If you don't see the option to reinstall the Word Add-in, open Tools → Add-ins and ensure that Zotero Word for Mac Integration is present and enabled. If it is missing, see Zotero toolbar doesn't appear.
  2. If you have only non-English versions of Office installed, you can delete the Microsoft User Data folder if it contains nothing other than the Zotero scripts. You can then re-install the Zotero scripts by going to Tools → Add-ons → Extensions, clicking the “Preferences” button next to Zotero Word for Mac Integration, and clicking the “Reinstall Microsot Word Add-in” button.
  3. If you have both English and non-English versions of Office installed, you should copy the Zotero folder from ~/Documents/Microsoft User Data/Word Script Menu Items to the equivalent folder for your non-English version of Office. You can find the correct directory by selecting “About This Menu…” (or non-English equivalent) from the script menu and clicking “Open Folder”.

No response from plugin

If you getting no response when you attempt to use the Word plugin, try the following steps:

  1. Restart Word and try again.
  2. Close Word and go to Tools → Add-ons → Extensions in Zotero. Make sure Zotero Word for Mac Integration is listed and enabled. If it is disabled, enable it. If it is missing entirely, see Zotero toolbar doesn't appear. After re-enabling/re-installing Zotero Word for Mac Integration, open the Cite pane of Zotero preferences and click “Reinstall Microsoft Word Add-in” on the “Word Processors” tab. Restart Word and try again.

In Word 2011, this can also indicate an issue with Visual Basic for Applications. If the above steps do not resolve the issue, follow these steps for resolving Visual Basic for Applications-related issues.

Visual Basic for Applications error

Some Word 2011 users may see the following message upon attempting to insert a citation or bibliography into any Word document using the Script menu:

“Zotero could not perform this action. Please ensure that a document is open. If you have performed a custom installation of Office, you may need to run the installer again, ensuring that “Visual Basic for Applications” is selected.”

Attempting to use the Zotero toolbar may result in no response, accompanied by an error message reading “Word could not fire event” when closing the document.

This error indicates that Visual Basic for Applications is malfunctioning, which may happen for several reasons:

  • Office 2011 may have been installed without Visual Basic for Applications. If you did not select Visual Basic for Applications during installation, or if you're not sure, reinstall Office 2011, making sure to select this option.
  • A character with an accent or diacritic may be present in the path to Microsoft Word (e.g., in the name of your hard disk).
  • The OLE Registration Database may be corrupt. Delete the OLE Registration Database, located in Home/Library/Preferences/Microsoft/Office 2011. Word will regenerate this file the next time it is opened. (On macOS Lion and later, the Library directory is hidden by default, but you can open it by holding down the Option key and selecting it from the Go menu.)

Error with Word 2008 after using Migration Assistant

After using Migration Assistant to move your applications and documents from an old computer to a new computer, upon attempting to use Zotero from within Word, you may see the following error:

“Zotero experienced an error updating your document. [Exception… ”'The operation couldn't be completed. (OSStatus error -1728.) @[getDocument:application.m:100]' when calling method: [zoteroIntegrationApplication::getDocument]“ nsresult: “0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)” location: “JS frame :: chrome://zotero/content/xpcom/integration.js :: _callIntegration :: line 273” data: no]”

Migration Assistant transfers an incomplete copy of Office 2008 that lacks files required for Zotero to function properly. Delete the copy of Microsoft Office created by Migration Assistant and reinstall Office from the original discs, or copy it manually from your old computer to your new computer using a USB flash drive or network share.

Linux

The Zotero Word for Windows plugin does not work out of the box under WINE, CrossOver Office, or other compatibility environments for Linux. We do not support running the Word for Windows plugin under Linux, and advise users to use LibreOffice instead. If you absolutely must run Zotero in WINE, this forum thread has some helpful tips.

As of March 2016, the following steps should work getting Office 2010 run with Zotero.

1. Install Office 2010 and Zotero on Wine

2. Change directory to /home/%user%/.wine/drive_c/users/%user%/Application Data/Microsoft/Word/STARTUP/. Substitute “Zotero.dot” file with this file

3. Open Zotero.

4. Open Microsoft Word.

Thanks to Sudarlin Laoddang for providing these instructions on his blog.

LibreOffice

All Platforms

Zotero requires LibreOffice 5.2 or later. If you are using an older version, upgrade to the current version of LibreOffice. See System Requirements. Apache OpenOffice and NeoOffice are based on older versions of LibreOffice and are not supported by Zotero.

Installation error

At the last step of LibreOffice Integration installation, you may see the message

“An error occurred installing Zotero LibreOffice Integration.”

If you experience this error during plugin installation:

  • Check that LibreOffice is up to date, as new Java releases sometimes introduce incompatibilities with LibreOffice.
  • Open the LibreOffice options dialog by choosing Tools → Options (Windows/Linux) or LibreOffice → Preferences… (Mac). In the dialog, click LibreOffice → Java (or Advanced). Ensure that “Use a Java runtime environment” is checked, and that a JRE is selected in the list below. (It may take a few seconds to load.) If no JRE appears in the list, install Java JRE.

Next, restart the installation process, by restarting Zotero. In Zotero select Tools → Add-ons. The page should display the Zotero LibreOffice Integration extension. Click the preferences button for this extension which will display the Cite pane of Zotero preferences. Click the Install LibreOffice Add-in button on the “Word Processors” tab.

When you are asked to locate your LibreOffice installations, ensure that your LibreOffice installation is listed. (You can add new LibreOffice installations by clicking the “Add Directory…” button below.)

If installation continues to fail, repeat the same steps, but click the Manual Installation button. This will open a folder containing the integration component to be installed within LibreOffice itself. Double-click this component to install it, or select Tools → Extension Manager within LibreOffice, click the Add button, and navigate to the component. While this is unlikely to succeed, it will provide further information about the cause of the installation failure.

If you receive an error stating “Could not create java implementation loader” when attempting to perform a manual installation, follow the instructions below for the Windows, Mac, or Linux. If you receive an error stating “JNI exception occurred” on Linux, follow these instructions. For errors not listed below, post the error you receive during manual installation to the Zotero forums.

Toolbar is missing

Check if there's an entry for Zotero under View → Toolbars. If not, look for the Zotero LibreOffice Integration plugin in Tools → Extension Manager. If it's in not there, return to Zotero and the Cite pane of Zotero preferences. On the “Word Processors” tab, click the “Install LibreOffice Add-in” button. If you get an error, refer to installation troubleshooting instructions.

NullPointerException or lastDataListener is undefined error

In Zotero LibreOffice Integration, when attempting to add or edit a citation or bibliography, you may see the message

java.Lang.NullPointerException at org.zotero.integration.ooo.comp.Comm.getMessageResponse

or the message

[JavaScript Error: “_lastDataListener is undefined” … when calling method: [zoteroIntegrationApplication::getActiveDocument]

This error indicates that the version of the extension within Zotero does not match the version of the extension within LibreOffice, typically because installation failed. Try reinstalling the plugin. If the installation fails, or you continue to experience this error after reinstalling, see the above section on how to resolve an installation error.

Users with other word processor integration plugins (Word for Mac or Word for Windows) installed should also make sure that those plugins are the latest available versions.

Add Extension(s)...does not exist error

When attempting to manually install Zotero LibreOffice Integration, you may see the message

Add extension(s): «DIRECTORY»/Zotero_LibreOffice_Integration.oxt does not exist

We believe this is caused by a corrupt LibreOffice profile directory. Move or delete the LibreOffice profile directory, then follow the instructions above to reinstall the Zotero LibreOffice extension. (This will revert any LibreOffice settings you have customized to their default state.)

Windows

Could not create java implementation loader

Upon manual installation of the LibreOffice component, you may see the message

“Could not create java implementation loader”

This error reflects a faulty Java installation within LibreOffice. This issue affects not only Zotero, but any LibreOffice extension that uses Java. Follow the steps below, testing whether manual installation succeeds after each.

  • Check that LibreOffice is up to date, as new Java releases sometimes introduce incompatibilities with LibreOffice.
  • Make sure that Java is installed and enabled in LibreOffice. Choose Tools → Options → LibreOffice → Java (or Advanced). Ensure that “Use a Java runtime environment” is checked, and that a JRE appears in the list below. (It may take a few seconds to load.)
  • Remove the Zotero LibreOffice Integration component from Tools → Extension Manager and uninstall and reinstall LibreOffice.
  • If you have recently upgraded from Java 6 to Java 7, you may need to follow these instructions to fix your Java installation. Oracle's Java installer does not completely remove older versions of Java, and this can confuse LibreOffice.

Mac

Could not create java implementation loader

Upon manual installation of the LibreOffice component, you may see the message

“Could not create java implementation loader”

This is usually caused by an outdated version of LibreOffice that does not properly locate the system Java installation. It can be resolved by installing LibreOffice 5.2 or later.

LibreOffice 5 on macOS 10.11+: No response from plugin

Problem: LibreOffice 5 does not currently recognize the Java Runtime Environment (JRE), and Zotero's plugin therefore doesn't work.

Solution: Uninstall the JRE and install the Java Development Kit (JDK) instead.

  1. Uninstall the JRE
  2. In LibreOffice:
    1. Check in Prefs → Advanced if JDK 1.8.xx is actually selected in the box
    2. Go to Tools → Extension Manager, scroll down to “Zotero LibreOffice Integration“, and click on it. You should see an “Enable” button appear.
    3. After enabling, the Zotero buttons in the LibreOffice toolbar should be responsive.

Tested successfully with LibreOffice 5.2.4.2 / JDK 1.8.0_112 / LO Integration Plugin 3.5.12 / Zotero 4.0.29.16 / macOS 10.12.2.

macOS 10.11+: Appears to freeze upon using a Zotero function

Some operations, such as trying to edit a bibliography before inserting a citation, should pop up an error dialog about an illegal operation. On macOS 10.11+ these dialogs fail to display, but freeze the rest of the LibreOffice process until they are dismissed. Until this is fixed, you can dismiss them by pressing Esc, Space, or Enter on the keyboard.

Linux

JNI exception

Upon manual installation of the LibreOffice extension, you may see the message

(com.sun.star.uno.RuntimeException) { { Message = JNI exception occurred“, Context = (com.sun.star.uno.XInterface) @7f01b00518b8 (ImplementationName = “com.sun.star.comp.stoc.JavaMachine”) } }

The most common cause of this error is a deselected Java installation due to a system update. To fix this, open Tools → Options, select LibreOffice → Java (or Advanced) on the left, press the radio button to the left of your Java installation, and close LibreOffice. You should now be able to reinstall the LibreOffice extension from within Zotero.

Could not create implementation loader, or clicking toolbar buttons does not have an effect

On some Linux installations the Zotero toolbar refuses to install properly in LibreOffice, or is visible in LibreOffice, but clicking the buttons has no effect.

Installing the libreoffice-java-common package, available in the repositories of most common linux distributions, usually solves this issue.

You may still need to activate the extension: In LibreOffice go to Tools → Extension Manager Select “Zotero LibreOffice Integration” and click the “Activate” button.

Writer crashes upon interacting with Zotero

There is a known bug in current 32-bit Linux kernel that causes a 32-bit JRE to crash when used with LibreOffice.

The current solution is to install a 64-bit version of LibreOffice and JRE. You will need to upgrade to a 64-bit version of Linux if you are running a 32-bit version of an OS.