Translations of this page:

How do I import a Mendeley library into Zotero?

Zotero includes support for directly importing from a Mendeley database into Zotero via File → “Import…”, but due to recent changes by Mendeley some extra steps may be required.

Mendeley Database Encryption

Mendeley 1.19 and later have begun encrypting the local database, making it unreadable by Zotero and other standard database tools. Mendeley made this change a few months after Zotero publicly announced work on an importer, despite having long touted the openness of its database format as a guarantee against lock-in. At the same time, Mendeley continues to import data from Zotero’s own open database, as it has since 2009.

The Mendeley 1.19 release notes claimed that the encryption was for “improved security” on shared machines, yet applications rarely encrypt their local data files, as file protections are generally handled by the operating system with account permissions and full-disk encryption, and anyone using the same operating system account or an admin account can already install a keylogger to capture passwords. Mendeley later stated that the change was required by new European privacy regulations — a bizarre claim, given that those regulations are designed to give people control over their data and guarantee data portability, not the opposite — and continued to assert, falsely, that full local export was still possible, while repeatedly dismissing reports of the change as “#fakenews”.

Direct access to the Mendeley database is the only local way to export the full contents of one’s own research. The export formats supported by Mendeley don’t contain folders, various metadata fields (date added, favorite, and others), or PDF annotations. Mendeley offers a web-based API, but it only contains uploaded data, so relying on it would mean that anyone wanting to export their own data would first need to upload all their data and files to Mendeley’s servers. The API is under Mendeley’s control and can be changed or discontinued at any time.

The Import Process

If you haven’t yet upgraded to Mendeley 1.19:

Start the import in Zotero by going to File → “Import…” and choosing the “Mendeley” option.

If you’ve already upgraded to 1.19 and have an automatic backup of your Mendeley SQLite database in the Mendeley data directory:

Locate your Mendeley data directory and look for a backupSlot1 (or higher) folder. If you see a database in the form <email>@www.mendeley.com.sqlite, copy it into the data directory one level up. Then start the import in Zotero by going to File → “Import…”, choosing the “Mendeley” option, and selecting that database.

If the backupSlotN folder contains an .sqlite filename with a long string of random characters, the backup has already been overwritten by the encrypted database. Check another backupSlot folder or use one of the methods below.

If you’ve already upgraded to 1.19 and have a recent backup of your Mendeley SQLite database:

Start the import in Zotero by going to File → “Import…”. If you haven’t moved your backup files back into the Mendeley data directory, use the file option to select the <email>@www.mendeley.com.sqlite or online.sqlite database in your backup directory.

If you’ve already upgraded to 1.19 and are not able to import from a recent backup of your Mendeley SQLite database:

It's possible to recreate an unencrypted database by syncing from an older version of Mendeley Desktop. However, this requires syncing all data and files to Mendeley's servers before downgrading. Even syncing data alone isn't sufficient: Mendeley sync doesn't make any information about attached files available unless you actually sync the files themselves.

If you don't want to sync any data to Mendeley's servers, your only option is to use one of the available export formats, such as BibTeX, to transfer your data to Zotero. As discussed above, you'll lose your folder structure and some other data.

If you're syncing your library data but don't want to sync files, you'll need to manually relink files in Mendeley after downgrading or in Zotero after importing.

(Note that at Zotero we strongly believe you should be fully in control of your own research data, and we don't think you should have to make these choices, but these are the options given the design decisions Mendeley has made.)

If you're comfortable syncing your data to Mendeley, or have already done so, here are the steps:

  1. Make sure you've synced all data and — if you want to avoid reassociating files manually — files to Mendeley's servers.
  2. Move your database out of the Mendeley data directory to a temporary location.
  3. Download Mendeley 1.18.
  4. Perform a fresh sync to pull down your Mendeley data from the Mendeley servers.
  5. Start the import in Zotero by going to File → “Import…” and choosing the “Mendeley” option.

Mendeley 1.18 installers

Troubleshooting

Make sure you're running the latest version of Zotero available via Help → “Check for Updates…”.

If you're running the latest version and something doesn’t come through how you expect or you run into any trouble, let us know in the Zotero Forums.

kb/mendeley_import.txt · Last modified: 2018/06/21 05:12 by dstillman