Translations of this page:

Zotero 2.1

We are excited to announce the release of Zotero 2.1. Zotero 2.1 is a major update over 2.0, offering many new features and bug fixes, including:

  • Firefox 4.0 compatibility1)
  • A next-generation citation engine
    • citeproc-js, written by Frank Bennett
    • Supports CSL 1.0 styles and includes many new features and bug fixes
  • Improved word processor integration
  • Support for displaying Zotero as a Firefox tab
  • A customizable Locate menu
  • Improved performance

See the changelog for a complete list of changes.

To install Zotero 2.1, click the “Download” button on the Zotero home page. Zotero 2.1 requires Firefox 3.6 or newer.

Word Processor Plug-ins for Zotero 2.1

Upgrading

Upgrading from Zotero 2.0

Upgrading from Zotero 2.0 is easy: just click the Download button on the Zotero home page. After installation, Zotero will prompt you to convert your 2.0 database to the new format used by 2.1, after which you will no longer be able to use your database with Zotero 2.0. Zotero will automatically back up your database in your Zotero data directory before upgrading it.

Upgrading from Zotero 1.0

To upgrade from Zotero 1.0, click the Download button on the Zotero home page. After installation, Zotero will prompt you to convert your 1.0 database to the new format used by 2.1. When upgrading from Zotero 1.0, you should take extra precautions in case you run into trouble:

  • Back up your data before upgrading your database. While Zotero automatically backs up its database before every upgrade, the upgrade process from Zotero 1.0 to Zotero 2.1 requires irreversible changes to both the Zotero database and the attachments directory. Without a backup of your entire Zotero data directory, you will be unable to go back to Zotero 1.0 without losing data.
  • Pick the right time to upgrade. If you have a large database and/or a slow computer, the upgrade process may take a number of hours to run. You may also run into unforeseen issues after upgrading. Consider delaying your upgrade if you have an important deadline coming up soon and you don't have time for troubleshooting.

Don't want to upgrade now? If you've installed 2.1 but haven't yet upgraded your database, you can reinstall Zotero 1.0, but note that Zotero 1.0 is no longer supported and no longer receives translator or style updates.

1) Mac Word integration requires Mac OS X 10.6 (Snow Leopard) or later for Firefox 4 compatibility
2.1.txt · Last modified: 2017/11/22 05:31 by bwiernik