Translations of this page:

We're in the process of updating the documentation for Zotero 5.0. Some documentation may be outdated in the meantime. Thanks for your understanding.

How do I import records from EndNote?

Many people coming to Zotero already have extensive collections stored in other reference management software. The following information describes how to make the move from EndNote to Zotero, but the same basic steps apply to many other reference management systems that can export to the RIS format.

Exporting Your Library from EndNote

Installing RIS Output Style

Zotero can't directly import “.enl” EndNote libraries, so the first step is exporting your EndNote library for import into Zotero. The best export format for this is RIS. You may already have the “Reference Manager (RIS) Export” style available in EndNote, but we still recommend that you obtain the latest version of this style from the EndNote Output Style repository. Once you download the style file, place it in your <EndNote folder>\Styles directory (overwriting any existing file with the same name). Alternatively, you may follow style installation directions provided by EndNote.

If you have EndNote open, restart it at this point.

Modifying the RIS Output Style

This section is only applicable if you want Zotero to import file attachments

At the time of this writing, the RIS output style provided by EndNote does not include File Attachments for Journal Article entries during export. Due to licensing limitations we cannot provide you with the modified output style, but you can easily modify it yourself.

  • In EndNote, go to the Edit menu > Output Styles. Select “Open Style Manager…”, find the “RefMan (RIS) Export” style in the list, and click Edit. A style editor window will appear.
  • On the left side of the window, select “Templates” under “Bibliography”.
  • On the right side of the window, click the “Reference Types >” button and select “Journal Article”. The view will scroll to the “Journal Article” section.
  • Confirm that the following line appears in the template (or copy-paste it from this web page to avoid any mistakes) anywhere between the line starting with TY and the end of the Journal Article section (right after KW and before L4 should be the most appropriate spot):
L1  - `File Attachments|`
  • Now go to the File menu and select Save.
  • You may close the Style Editor window at this point and go back to your library window.

Preparing Your Library for Export

It may be necessary, with older EndNote libraries, to convert figures to attachments before you export to a RIS file. This is done by going to the References menu > Figure and selecting “Convert Figures to File Attachments…”

Exporting EndNote Records

  • If you wish to export a subset of your EndNote library, select the entries you wish to export.
  • Now, go to the File menu > Export. A dialog box will pop up asking you where to save the export file.
  • Navigate to your EndNote data directory (typically, My Documents\endnote.Data). This directory contains a 'PDF' folder, but you should be sure to select the data directory rather than any sub-directory. This is important: Zotero will look for file attachments in a directory relative to the RIS file you are exporting now. If this file is located in the wrong place during import into Zotero, file attachments will not be imported.
  • Select “Text File (*.txt)” in the “Save as type” dropbox. Select “RefMan (RIS) Export” in the “Output style” dropbox. If you wanted to export a subset of your library and had selected items to export, check the “Export Selected References” box. Otherwise, make sure it is unchecked.
  • Click “Save”.
  • You may close EndNote at this point.

Importing into Zotero

There are a few Zotero hidden preferences that affect RIS import and, if desired, must be set before importing the RIS file into Zotero. Notably, ignoreUnknown may be toggled to make Zotero create note attachments for data that it cannot store in proper fields. This may be useful if the data in your EndNote library is not entered in a standard way or if you want to keep data, which Zotero does not recognize and does not use, like author address. Disabling this preference (toggling it to false) may generate a large amount of note attachments, which have a significant impact on Zotero's performance. It is recommended to clean up these notes after import. Additionally, the keepID preference will add the EndNote item ID to the note attachments. This would allow you to reference the original item in EndNote, which may be helpful for detecting transfer errors.

If you are not importing into an empty library, we highly recommend making a backup of you Zotero data directory. This will avoid a lot of frustration if you do not like the way your library has transferred. In that event, simply restore your library from the backup.

You should also temporarily disable automatic sync (if enabled) via Preferences → Sync → uncheck “Sync automatically”. Once you are satisfied with the way your references transferred, perform a manual sync (green circular arrow at the top right of the Zotero pane) and then re-enable automatic sync.

In Zotero, go to the Gear menu and select “Import…” A dialog box will appear asking you to select the file to import. Navigate to the location where you exported your EndNote library (if you followed the above instructions, this should be My Documents\endnote.Data) and select the RIS file. Note that the actual file extension may be “.txt” instead of “.ris”. Click Open.

The EndNote library will be imported into a separate collection. You may remove the collection (right-click > Remove Collection…) without deleting the imported references (they will be moved to the root of your library).

Because Zotero and EndNote do not have identical reference types and the type of information that is recorded for each reference type is also not the same, some of the values exported from EndNote cannot be imported into Zotero and stored in a dedicated field. Additionally, Zotero may not recognize some entries in the RIS file and will be unable to assign these values to a particular field. In these cases, Zotero will collect all the values that cannot be properly imported and store them in a note that will be attached to the imported reference. You may be able to manually assign some of these values to certain fields in Zotero. If there is no valuable information in such notes, you can safely remove them.

Tip: You can display all of the notes generated automatically during the import using the “_RIS import” tag. To select and delete these notes after clicking the “_RIS import” tag, select one of the notes and press Ctrl+A. Then, right-click and choose “Delete Selected Items from Library…”

Getting Further Help

If you have any issues related to importing and exporting references, try searching the forums. You may be able to find quick tips to help you solve your problem. If your search doesn’t turn up the answer you were looking for, post your question to the forums in a new thread. This is the quickest way to get information from the Zotero team.

kb/importing_records_from_endnote.txt · Last modified: 2017/02/10 22:51 by adamsmith