Translations of this page:

This is an old revision of the document!


レポート

Zoteroを使えば、あなたのコレクションの中のアイテムについて簡単かつ素早くレポートを作成することができます。レポートは単純なHTML文書ですので、印刷したり、ウェブ上に公開したり、電子メールで送ったりすることができます。

レポートの作成

レポートを作成するには三つの方法があります。どんなアイテムでも、あるいは複数のアイテム、あるいはコレクション全体を、右クリック(Mac ではctrlクリック)すれば、Zoteroで「アイテムからレポートを作成…」することができます。ドロップダウンメニューでこの選択肢を選んだ後、Zoteroは選択されたアイテムについてのHTMLで書かれたレポートを作成し、ブラウザの画面に表示します。

コレクションを右クリックして中身全体についてのレポートを作る
または、任意のアイテムをひとつまたは複数選んでそれらのレポートを作る

現在のところ、レポートは各アイテムのすべての細目を含んでいます。将来的には、利用者はどの細目を含めるか指定することが可能になります。この選択機能が加わるまでは、Jason Priemによる Zotero report cleanerを使えば、不要な細目をレポートから除去することが可能です。

レポートは単純なHTML文書ですので、印刷したり、ウェブ上に公開したり、電子メールで送ったりすることができます。

レポートの実例

レポートでのアイテムの順序の並べ換え

初期設定では、レポートは題名の昇順(0-9, A-Z)で並べられます。アイテムの順序を変えたいときは、レポートのURLの末尾に、“?sort=“に続けて、レポートの並べ替えに使いたいアイテムの細目の種類を指定してください。 ”/d”を細目名の後に追加することで降順にすることができます。これらを同時に行うと例えば、以下のようになります。

zotero://report/items/8077-15035-1713-4917/html/report.html?sort=title,date/d

以下に他の並べ替えに便利な細目の種類を紹介します。

?sort=title?sort=firstCreator
?sort=date ?sort=accessed
?sort=dateAdded ?sort=dateModified
?sort=publicationTitle ?sort=publisher
?sort=itemType ?sort=series
?sort=type ?sort=medium
?sort=callNumber ?sort=pages
?sort=archiveLocation ?sort=DOI
?sort=ISBN ?sort=ISSN
?sort=edition ?sort=url
?sort=rights

個別のアイテムを選択するのではなく、コレクションから新しいレポートを生成する場合、Zoteroは自動的に現在の並べ替え順に従ってレポートを作ります。

レポートの共有

レポートの保存

ウェブ上のあらゆるHTML文書を保存するのと同様に、レポートをを保存することができます。ファイル→「名前をつけてページを保存」を選んで、保存先を指定してください。あなたのレポートをウェブ上に公開したり、電子メールで同僚に送信したりできます。

レポートの印刷

レポートは、ブラウザで閲覧する他のHTML文書を印刷するのとまったく同様に印刷することができます。ブラウザのメニューから、ファイル→「印刷」を選んでください。

レポートの高度な使い方

メモを整理するためにレポートを利用する

With reports, it's easy to organize your notes into an outline.

By default, Zotero will group child notes in reports together under their parent items. To separate notes from their parent items, you'll need to change a hidden preference. Type “about:config” into Firefox's address bar, search for the “extensions.zotero.report.combineChildItems” setting in the list that comes up, and double-click it to toggle it to “false”. Child notes will now appear separately, making it easier for you to use Zotero as an outlining tool.

To build your outline, add an outline number at the beginning of each note you want to include, e.g. 1.1, 1.2, 2.1. Then select the notes, right-click/control-click on them, and select “Generate Report from Selected Items…” from the menu. A report should appear in the browser with each note you have selected. If you want, you can then print the report from your browser.

Note: Because 10.0 will sort before 6.0, make sure to insert the appropriate number of zeroes (e.g. 06.0) if your outline goes into 10 or more sections.

If you are working with a great number of notes and you do not want to manually select each one, tags and advanced searches can make life easier. First tag each note with a description, such as “chapter one”. Then create an advanced search for “item type” [is] “note” and “tag” [is] “chapter one”. Now save the advanced search. Right-click on your saved search and select “Generate Report from Saved Search…”. This will create a report including only the notes tagged “chapter one”.

メモの中身を検索するためにレポートを利用する

メモの中身を検索するためにはレポートは大変便利です。Zoteroの基本検索、高度な検索はコレクションの中のすべての情報を見るために充分に強力ですが、長大なメモを検索するためにはあまり便利ではありません。検索を行いたい文献項目のレポートを作成して、Firefox内蔵の検索機能を使ってみてください。Firefoxのメインメニューから、Edit→Find in this page…を選んでください。ブラウザ画面の下部に検索用のボックスが表示され、表示されているレポートに対して検索を行うことができます。NextとPreviousボタンでレポートの中を移動し、また「すべてを強調表示」ボタンによって検索語句を浮き立たせることができます。

レポートを教材として利用する

レポート機能は指導者が学生の作文の途中経過を調べるのにも使えます。いつアイテムを取り込んだかを記録した自分の Zotero ライブラリのレポートや、そのアイテムにどのようにメモやタグを付けたかを記録したレポートを数回のクリックで学生たちは作ることができます。これらのレポートは学生が彼らの研究アイテムをどのように関連付けているかを示し、学生はこれを研究進捗状況のレポートとして提出することができます。指導者たちはこの包括的なレポートは研究の進捗を見守り励ますのに便利な方法だと気づいているようです。