Table of Contents

Debug Output Logging

If you've been asked to provide a Debug ID (which is different from a Report ID) to help troubleshoot a problem, follow these simple steps:

Zotero

  1. In the Help menu, go to Debug Output Logging and select Enable, or use “Restart with Logging Enabled…” to generate debug output from Zotero startup. (If you're not able to access the Help menu, see Reporting Startup Errors instead.)
  2. Immediately perform the relevant action (syncing, saving, importing, etc.).
  3. Before doing anything else, return to Help → Debug Output Logging and click Submit Output, which will disable logging and submit the output to zotero.org. A window should pop up containing a Debug ID (e.g., “D12345678”). Click “Copy to Clipboard” and paste the Debug ID into your forum thread.

Zotero Connectors (Firefox, Chrome, and Safari)

  1. Open the Zotero Connector preferences
    • Firefox: type about:addons into the address bar, press return, and click the “Preferences” button next to the entry for “Zotero Connector”.
    • Chrome: type chrome://extensions into the address bar, press return, and click the “Options” link underneath “Zotero Connector.”
    • Safari: right-click anywhere on a webpage and select “Zotero Preferences…”
  2. In the Advanced tab of the Zotero Connector preferences, check the box next to “Enable Logging.” Do not close this window.
  3. Immediately perform all the relevant actions (e.g., import an item from a web page).
  4. Go back to the Advanced tab of the Zotero Connector preferences and click Submit to Zotero Server.
  5. You will be provided with a Debug ID (e.g., “D12345678”). Please post the Debug ID to the forums.
  6. Uncheck the box next to “Enable Logging.”

Error Submitting a Debug Log

If submitting output fails, you can return to the Debug Output Logging menu and select View Output, go to File → “Save…”, choose Format: “Text Files”, and save the output to a file, which you can email to support@zotero.org with a link to your forum thread. It can be helpful to ZIP the file before emailing it.

Logging to a Terminal Window

If you'd like to regularly follow Zotero's debug output in real-time, it may be preferable to have Zotero log to a terminal window.

macOS

Windows

Start Zotero via the Cygwin terminal (not cmd.exe):

Linux

Start Zotero via the command line, adding the -ZoteroDebug command-line flag.

Developer Note

To enable Zotero debug output permanently, set extensions.zotero.debug.log to true in the Zotero config editor, accessible from the Advanced pane of the Zotero preferences, and then start Zotero from the command line.